SAP Knowledge Base Article - Public

3476224 - After adding a username in the email address field the error message "Enter a valid email address" pops up

Symptom

After adding a username in the email address field the error message "Enter a valid email address" pops up when saving the changes in the contact information portlet.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Navigate to Contact Information Portlet
  2. Add a username or any other word in email address field
  3. When saving it the message pops up "Enter a valid email address"

Cause

The "Activate Email Validation in scorecard" switch had become universal and could no longer be disabled in Company System and Logo Settings, this means that when adding any information in the email address field that is not in the XXX@YYY.ZZZ format, the system will not allow saving the change.

However, it was reverted and can be disabled in Company System and Logo Settings again.

Resolution

The switch can be disabled again so that this validation allows changes to be saved.

See Also

KBAs: 2265894 - Email Validation in Employee Central - SAP for Me

Guide:

Keywords

ECT-236476, 1H2024, email address, error, username, valid, contact information, email validation, employee central, employee profile, successfactors, SF, EC, EP , KBA , LOD-SF-EC-PER-EML , Email Info - Config, Rules, RBP, UI , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM suite all versions

Attachments

Pasted image.png