Symptom
On the ticket's-item with the Work Progress as Finished, on performing Undo Work Progress and further set back to Finish Work again does not re-calculate the Actual End date value.
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Search and open the Ticket LMN (where LMN represent the ticket id).
- Go to the Items facet and select line-item YY (where YY represent the line-item number).
- You can see the Work Progress of line item YY is Finished and have the Actual End Date as xx1.yy1.zzzz1 H1:M1 (where xx1.yy1.zzzz1 H1:M1 is the date and time, when the work progress was 1st time set to finished).
- Select line-item YY and click on the More option and select Undo Work Progress.
- You can see the work progress of item YY change from Finished to Started.
- Now again change the line-item YY work progress from Started to Finished as on xx2.yy2.zzzz2 H2:M2(where xx2.yy2.zzzz2 H2:M2 is the date and time, when the work progress was again set back to finished).
- You can see Actual End date for line-item YY is still as xx1.yy1.zzzz1 H1:M1, not re-calculated to xx2.yy2.zzzz2 H2:M2.
Cause
An Actual End Date is automatically calculated, when 1st time change the Item's Work Progress to Finished. This date value will not be re-calculated every time you set the Work Progress to Finished.
Resolution
This is current system behavior.
If you want to re-calculate the Actual End Date, you need to do it manually as propose below.
- Go to the Service work center.
- Go to the Tickets view.
- Search and open the Ticket LMN.
- Go to the Items facet and select line-item YY.
- You can see the Work Progress of line item YY is Finished and have the Actual End Date as xx1.yy1.zzzz1 H1:M1.
- Select line-item YY and click on More option and select Undo Work Progress.
- You can see the Work Progress of item YY change from Finished to Started.
- Now, if you need manually change the Actual End Date of line-item YY to xx2.yy2.zzzz2 H2:M2 and then again set back again to Finish Work.
- You will now have the manually changed value for Actual End Date as xx2.yy2.zzzz2 H2:M2.
Keywords
Ticket's Item, Work Progress, Undo Work Progress, Actual End date, Finished, Finish Work , KBA , LOD-CRM-SRP , Service Request Processing , How To