Symptom
Receiving blank email notification after completing a new hire
A document generation template is maintained in the CC section of the New Hire Workflow
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Add New Employee
- Fill in the details
- Submit
- All document template placeholders are blank in the email notifications received.
Cause
This issue (reference ECT-237833) has been caused due to 1H 2024 Release.
Resolution
Engineering Team are planning to fix the issue in 2H 2024, however it's not yet confirmed. This KBA will be updated once we have more details.
Workaround For Add Contingent Worker Scenario:
There is a "Contingent Workers Hire Notification" send to Managers as defined in the workflow and also "Welcome Message for Contingent Workers" that can be enabled in the "Email Notification Templates Settings".
Or
Disabling "Enable Centralised Services to Add Contingent Worker and Add Assignment" feature in Company System and Logo Settings > system is working correctly, no blank fields in the email.
So kindly use that feature until the issue is fixed.
Click on star to bookmark this article to receive updates about this issue. For more information about updates from subscribed KBAs, you can refer to the KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs.
See Also
2606814 - Custom workflow template behavior for direct mapped and rule mapped fields
Keywords
KI2405, 1H2024, b2405, contingent worker, new hire, hire, blank placeholders, blank email, hire email, INC8406723, ECT-237833, Major case: CS20240007750442 , KBA , LOD-SF-EC-CWF , Contingent Workforce , LOD-SF-EC-HIR-NEW , Add New Employee Wizard , LOD-SF-EC-DOC , Document Generation , Known Error