SAP Knowledge Base Article - Public

3476367 - Incorrect data displayed in the Earned Profit Overview for KPI Report

Symptom

The Report Earned Profit Overview for KPI (FINPRFU30_Q0003) shows sales order from the previous years though the Accounting Period/Year is entered as 'Year to Date' in the data selection field.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Business Analytics Work Center.
  2. Go to the Design Reports View.
  3. Open the Report Earned Profit Overview for KPI (FINPRFU30_Q0003).
  4. Enter the Company ID and select the Account Period/Year as 'Year to Date' and click on Apply.
  5. Change the report view to Operating Profit by Profit Center and Sales or Service Unit.
  6. Select the Row Fields, Profit Center and Sales Document ID in the view section.
  7. Expand the Profit Center ID in the column Profit Center/Sales Document ID/Cost Center/Customer/Project
  8. A Sales Order 123 (123 is the Sales Order ID) from the previous years is displayed. 

Cause

The associated Invoice Status was changed from 'In Process' to 'Completed' and the Sales Order's status was changed from 'In Process' to 'Finished' in the current year.

Resolution

To check the changes:

  1. Go to the Sales Orders Work Center.
  2. Go to the Sales Orders View.
  3. Select the sales order 123 and navigate to the Changes tab.
  4. You can notice the changes made to the sales order and the invoice status in the current fiscal year.

Therefore, the report includes this sales order from the previous year even though the Accounting Period/Year is entered as 'Year to Date' in the Data Selection field because it has accounting entries in the current fiscal year. 

Keywords

Earned Profit Overview for KPI Report, Sales Order, Changes, Incorrect, Invoice, accounting period, fiscal year , KBA , SRD-FIN-ANA , Analytics Content , How To

Product

SAP Business ByDesign all versions