SAP Knowledge Base Article - Public

3476450 - Payload size exceeds maximum size (2M) error on claiming with big attachment in Mobile app

Symptom

For Claim on Mobile app, there is an error when the attachment size more is than 2MB, though the maximum file size is 10M in provisioning setting.
Error: "Payload size exceeds maximum size (2M)"

Environment

SAP SuccessFactors Employee Central: Benefits on Mobile

Reproducing the Issue

  1. Login to Mobile app > Go to benefit of any user -> claim, then click one of reimbursement item
  2. Input the amount and add a file more than 2MB, then submit
  3. Error: 'Payload size exceeds maximum size (2M)'

Cause

The mobile variant uses a specific API call which restricts the request payload size to the specified limit.

Resolution

The behavior is expected and we suggest you to log an enhancement request with product team if larger size support is needed, or up-vote matching ideas following KBA-2090228.

Workaround: Use Desktop for claims or browser on Mobile to submit claims with larger attachments.

Keywords

1H2024, payload size exceeds, 2M, 2MB, attachment, Claim, mobile, limit, INC8424940, Payload size exceeds maximum size , KBA , LOD-SF-EC-GBF , Global Benefits , Product Enhancement

Product

SAP SuccessFactors Employee Central all versions