Symptom
For Claim on Mobile app, there is an error when the attachment size more is than 2MB, though the maximum file size is 10M in provisioning setting.
Error: "Payload size exceeds maximum size (2M)"
Environment
SAP SuccessFactors Employee Central: Benefits on Mobile
Reproducing the Issue
- Login to Mobile app > Go to benefit of any user -> claim, then click one of reimbursement item
- Input the amount and add a file more than 2MB, then submit
- Error: 'Payload size exceeds maximum size (2M)'
Cause
The mobile variant uses a specific API call which restricts the request payload size to the specified limit.
PS: 2MB is not just the attachment size, it represent the entire request payload size. Hence the supported upload file size would be still smaller than 2MB and it varies based on individual payloads.
Resolution
The behavior is expected and we suggest you to log an enhancement request with product team if larger size support is needed, or up-vote matching ideas following KBA-2090228.
Workaround: Use Desktop for claims or browser on Mobile to submit claims with larger attachments.
Keywords
payload size exceeds, 2M, 2MB, attachment, Claim, mobile, limit, INC8424940, Payload size exceeds maximum size , KBA , LOD-SF-EC-GBF , Global Benefits , Product Enhancement