SAP Knowledge Base Article - Public

3476481 - How to Delete Replicated Sales Order in SAP Cloud For Customer

Symptom

Sales Orders replicated from SAP S4HANA or SAP ERP cannot be deleted from Cloud for Customer UI. But the corresponding Order was already deleted in S4/ERP which is not communicated to C4C

Environment

SAP Cloud For Customer

Cause

Replicated Sales Orders will have external system reference links in C4C and these orders cannot be deleted directly from UI.

Resolution

  1. You have to send a deletion message to C4C to delete the Order. As the order has already been deleted in S4HANA, you cannot generate the deletion idoc automatically.
  2. Create the report available in the note https://me.sap.com/notes/2659555
  3. Provide S4/ERP order ID , Document type , C4C logical system as inputs and execute the report
  4. This will generate the deletion idoc in ERP/S4 system and sent to C4C logical system
  5. The deletion webservice message sent to C4C will delete the link and order from C4C

Keywords

C4C ; Delete Sales Order , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-LE-CQP , Customer Quote Processing , Problem

Product

SAP Cloud for Customer core applications all versions