SAP Knowledge Base Article - Public

3476690 - Account Utilities Overview Financial Details Are Not Showing Information While It Is Available in ISU System

Symptom

When opening a Contract Account, the financial data appears to be blank. However, upon checking the same Contract Account on the ISU system, all the necessary data is readily available, such as:

  • Invoices;
  • Payments;
  • Open Items;
  • Account History.

Environment

  • SAP Cloud for Customer
  • Utilities

Reproducing the Issue

  1. Go to the Utilities work center.
  2. Go to the Contract Accounts work view.
  3. Search and open the Contract Account ID 123456 (where 123456 refers to a generic Contract Account ID).
  4. Go to the tabs: 
    1. Invoice;
    2. Payments;
    3. Open Items;
    4. Account History.

Results: No data available.

Cause

The items in the ISU are more than a year old. By default, the C4C Contract Account Overview Service will only return records from the past 365 days. Therefore, these items are no longer displayed for Contract Account 123456.

 

Resolution

If you want to display this data, then BADI should be implemented for this.

  • Enhancement Spot: COD_UTILITIES_ERP_CUST_INFO.
  • BADI: COD_UTILITIES_ERP_CUST_BADI.
  • Interface: IF_COD_UTILITIES_ERP_CUST_BADI.
  • Method: ACCOUNT_OVERVIEW_PRE.
  • Parameter Structure: CV_INPUT.
  • fields: DATE_FROM,DATE_TO.

Keywords

Contract Account; Account; Utilities Overview; Financial Details; ISU System; COD_UTILITIES_ERP_CUST_INFO; BADI; COD_UTILITIES_ERP_CUST_BADI; IF_COD_UTILITIES_ERP_CUST_BADI; ACCOUNT_OVERVIEW_PRE; CV_INPUT; DATE_FROM,DATE_TO; Invoice; Payments; Open Items; Account History. , KBA , LOD-CRM-IND-UTL , Utilities , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications all versions