SAP Knowledge Base Article - Public

3477090 - Inbound Delivery Document Number not getting generated in correct sequence

Symptom

While creating an inbound delivery document it is noticed that the document number id that is being created is not in correct sequence.

For example :
Previous created inbound delivery document is A
Next created inbound delivery document is C
Ideally the next created inbound delivery document should be B.
(Here A,B,C refers to Inbound delivery document )

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Third-Party Order Fulfillment Work center
  2. Choose Third-Party Inbound Deliveries 
  3. Search for document id's with prefix name*
  4. It is noticed that some document number id's have been skipped.

Cause

The chance that a number is being missed could be caused by a change in the format of the number range or by a problem with the system buffer, which occurs when numbers are in the system buffer but another application launches in parallel. The number range selects this unused number and uses it later on when a new document is created.

Resolution

The system takes into account a chronological order while generating the Inbound Delivery ID, however it will be within the specified range.

See Also

2675078 - Gaps in Number Range of Outbound Delivery Numbers

3421070-Sales Order Numbering Gap

Keywords

Inbound delivery , Number range, Number range format, Inbound delivery document , KBA , AP-IDP , Inbound Delivery Processing , Problem

Product

SAP Business ByDesign all versions