SAP Knowledge Base Article - Public

3478588 - Duplicate Check Does Not Work

Symptom

Duplicate check not working for account.

 
 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customer work center.
  2. Go to Contact work center view.
  3. Search for XXXXX YYYYY, where XXXXX is the first name and YYYYY is the last name.
  4. Two records are identified.
  5. Click on first row to view XXXXX YYYYY, to open details.
  6. Cluck on Duplicate check.
  7. Pop up is seen with result"
    One potential duplicate found for business partner XXXXX YYYYY.
  8. Click on second row to view XXXXX YYYYY, to open details.
  9. Click on Duplicate check.
  10. Pop up is seen with result" Potential Duplicates (0).
Why the Duplicate check not identified for the contact XXXXX YYYYY with result displayed in step 9.

Cause

First record which was created with XXXXX YYYYY, did not had duplicate. Hence check of duplicate check reflect the duplicate result as 0 result found.

Second record created with XXXXX YYYYY, had the first record XXXXX YYYYY existing already. Hence duplicate check reflects in duplicate result one Potential Duplicate.

Resolution

First record when created as XXXXX YYYYY, did not have duplicate and hence one record will always reflect the as zero 0 Potential Duplicate. This is expected behaviour.

Note: If third record is created with name XXXXX YYYYY is created, it would show duplicate check result to reflect two potential records identified for two contacts with name XXXXX YYYYY, which exists already.

This KBA is valid for duplicate Check for Account as well.

Keywords

Duplicate Check, 0 potential duplicate, contact, Account , KBA , LOD-LE-BP-DUP , Business Partner Duplicate Check , LOD-CRM-ACC , Account , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2405