SAP Knowledge Base Article - Public

3478942 - Vendor details are not displayed in the Manage Business Partner Master Data app

Symptom

The vendor results are not displayed while searching with the exact external BP number "xxxx", However, the vendor results are displayed with the search "*XXXX*". 

Environment

 SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the Manage Business Partner Master Data app
  2. Navigate to adapt filters and add the field external business partner number
  3. Search for the external business partner number "xxxx"
  4. A blank page is displayed

Cause

There’s a blank space in front of an external BP number. 

Resolution

  1. Open Maintain Business Partner app or Manage Business Partner Master Data app. 
  2. Select the business partner.
  3. Navigate to the Identification tab.
  4. Choose the external business partner number.
  5. Remove the space in front of the external business partner.
  6. Save your entry.

Keywords

Vendor details, adapt filters results are not appearing, external business partner, Maintain BP  , KBA , LO-MD-BP , Business Partners , Problem

Product

SAP S/4HANA Cloud Public Edition all versions