SAP Knowledge Base Article - Public

3479114 - No Data for Contract Account and Premise During Ticket Creation

Symptom

While trying to create a ticket for from an account, the Contract Account and Premise data is not being populated.

Environment

  • SAP Cloud for Customer
  • ECC

Reproducing the Issue

  1. Go to the Customer work center.
  2. Go to the Account work view.
  3. Set query "All" view to display all the accounts.
  4. Search for the Account 123 and open it (Where 123 means Account ID).
  5. Go to the Tickets tab.
  6. Click on "New" button to create a ticket.
  7. On Click of OVS (Object Value Selector) for Contract Account and Premise.
  8. See that no data for Contract Account and Premises gets displayed.

Cause

The Integration Technical User, with which the backend service call happens, has an authorization group, however the corresponding business partner belong to other authorization group. Hence, the authorization check fails and the standard FM ISU_FINDER which is used to find the complete hierarchy for the business partner doesn't return any result. Hence, customer doesn't see any records. 

Resolution

Maintain the correct authorization group for the technical user.

Keywords

C4C; Cloud for Customer; ECC; Contract Account; Premise; CODINTEG; ISU_FINDER; Ticket. , KBA , LOD-CRM-IND-UTL , Utilities , How To

Product

SAP Cloud for Customer core applications 2405