SAP Knowledge Base Article - Public

3479313 - External candidates are not receiving password reset email while trying to reset the password for their account - Recruiting Management

Symptom

External candidates are not receiving password reset email when they click on forgot password in external career site.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Navigate to external career site
  2. Click on "Sign In" and "Forgot your password?"
  3. Type your e-mail address and no notification is received

Cause

One of the caused may be that the Candidate email address was updated in the Candidate Profile and the candidate is trying to log in with the contact email id instead of Primary Email id.

Primary email id is the one that was used by the candidate to create the account. Once the email id is updated in the candidate profile, the newly updated email will be the contact email id.

 
 
To check if the email id has been updated: This can be checked in the Candidate Profile Audit History.

Resolution

The candidate needs to log in to the account using the Primary email id. All the emails will sent to Communication email id but to log in Primary id needs to be used.

See Also

2210781 - External candidates are not receiving password reset email - Recruiting Management

3209167 - Behavior of candidate contactEmail and primaryEmail address - Recruiting Management

2958311 - Does Password Reset validates the Email Address - Recruiting Management

3168352 - How a candidate can reset career site password - Recruiting Management

Keywords

Password reset, external career site , candidate account sign in , KBA , LOD-SF-RCM-POR , Career and Agency Portals , Problem

Product

SAP SuccessFactors Recruiting all versions