SAP Knowledge Base Article - Public

3479554 - Guest User registration email is not being received by administrator

Symptom

When attempting to perform Self Registration as a Guest User, administrator do not receive registration email and user is not registered in the system, even though Successful Registration message is displayed and other User type emails are received (Forgotten Password, Registration, and other system emails)

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Configure Guest User to Self Register when Checking Out the Quote
  2. Click on the Guest link (usually https://<CPQ_TenantURL>/guest)
  3. Add a product to the quote
  4. Click on Check Out action
  5. On Login Page, click Register
  6. Fill needed information and click on Save
  7. Successful message is shown
  8. Administrator cannot see user in User Setup, no registration email is received nor any information is logged in CPQ Logger.

Cause

Company Name do not exist in CPQ System.

Resolution

  • It must be ensured that end user is filling Company Name with a company that exists in CPQ Tenant
  • If even after ensuring above topic registration still do not occur, it is required to engage Support Team providing a record or step by step on how guest user is registering.

See Also

Keywords

Guest, Check Out, Registration, Email, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed

Product

SAP CPQ 2023