SAP Knowledge Base Article - Public

3479756 - How-To Unlock Database User within Datasphere Space

Symptom

Database User within SAP Datasphere Space is locked after too many wrong password entries.

This applies for "Database User on Space-Level" (a.k.a. OpenSQL Schema DB User) as well as "Database User on Tentant-Level" (a.k.a. DB Analysis User).

Environment

SAP Datasphere

Reproducing the Issue

After entering the wrong password too many times, the Database user gets locked.

Cause

Entering the wrong password too many times.

Resolution

  1. Login to the Datasphere Tenant
  2. Click on Space Management
  3. Click on Edit under the Space where this Database user is defined
  4. You should see the user with the Status Locked
  5. Click on the icon Unlock 
  6. And click on Request New Password

Currently there is no way to unlock user from Datasphere's UI in a way the password is not changed. 

If a specific password is required, proceed with steps:

  1. Request New Password
  2. Access HANA DB Explorer using new password
  3. Run statement to set the old password as needed:
    ALTER USER <Insert DB User> PASSWORD <Insert the required password>

NOTE: It's only possible to adjust the User's own password. Even a DB Analysis User does not have privileges to change another DB User's password but for itself. 

Keywords

Datasphere user locked , KBA , DS-SEC , Security (Users, Roles) , How To

Product

SAP Datasphere all versions