SAP Knowledge Base Article - Public

3479785 - Error message "Unexpected error occurred, please contact system admin for help. " would appear on scheduled import jobs based on the import data connection to Google Drive in SAP Analytics Cloud (SAC)

Symptom

  • Create and schedule import job based on import data connection to Google Drive in a model
  • Observe this scheduled import job would fail intermittently with error message "Unexpected error occurred, please contact system admin for help. "

Environment

  • SAP Analytics Cloud 2024.8.10

Reproducing the Issue

  1. Log onto SAC
  2. Open a model
  3. Create an import job based on the import data connection to Google Drive in this model
  4. Schedule this import job to run daily
  5. Click on this import job and navigate to the Status panel
    => Observe that this import job would fail intermittently when running automatically on this scheduled time 
    => Also observe that this import job would not fail when running it manually

Cause

  • This issue is caused by the large number of concurrent calls to get the data from Google Drive.
  • This error is coming from the data source (Google Drive) side

Resolution

Workaround from SAC side:

  • Try not use exact times when scheduling import jobs because probably many other import jobs are scheduled to that exact time. For example, schedule import jobs on 07:13 instead of 07:00.
  • Try to consider import frequency. Import job frequency should be adjusted according to the needs. Too frequent import jobs are not the optimal in many data sources, it might cause overloading on the data source and sometimes even SAC.   

See Also

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Keywords

sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, model, account, google, drive, scheduling, failure, plugin, import, manual, epm service , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem

Product

SAP Analytics Cloud 1.0