Symptom
You are using the report "ISU_C4C_V2_TECH_OBJECTS_REPL" to replicate Premise and connection objects from SAP S4-ISU to SAP Service Cloud Version 2 and it fails with HTTP status code 500(in ISU) and 400 (in CPI).
Environment
- SAP Service Cloud Version 2
Reproducing the Issue
- Execute the report ISU_C4C_V2_TECH_OBJECTS_REPL.
- Check the SRT_MONI and messages fail with HTTP 500 error.
- Go into details, you are asked to check the CPI MPL ID for actual error message.
- You can find the error similar to "https://my123456.XX1.test.crm.cloud.sap/sap/c4c/api/v1/inbound-data-connector-service/message/sap.crm.premiseservice.entity.technicalobject" with status code: 400".
- Activate the payload trace and repeat the above steps , you can find detailed error like below.
{"error":{"code":"inbound-data-connector.100","message":"Failed to create the inbound message.","details":[{"code":"inbound-data-connector.200","message":"Attribute receiverCommunicationSystemDisplayId cannot be empty."}]}}. OR
{"error":{"code":"inbound-data-connector.100","message":"Failed to create the inbound message.","details":[{"code":"inbound-data-connector.202","message":"Invalid value XXXXXX for attribute receiverCommunicationSystemDisplayId."}]}}
Cause
The BADI Implementation "ISU_C4C_V2_TECH_OBJS_REPL" is not active. This report will use the BADI to determine the receiver system(Service Cloud V2 system id) and append it into the outgoing messages.
If the id is missing, Service Cloud will reject the messages and send the above error back to CPI - then the CPI MPL ID will be sent back to ISU with status 500.
Resolution
Implement the BADI "ISU_C4C_V2_TECH_OBJS_REPL" >> RECEIVER_ADJUST_DATA.
Use the statement APPEND 'sap_cloud_crm_my123456' TO ct_receiver_system in the BADI.
See Also
The Service Cloud V2 system id "sap_cloud_crm_my123456" can be found in the Settings >> Communication Systems >> Find the system ID with description "Default communication"
Keywords
"default communication system" "technical master data replication" "service cloud version 2" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem