Symptom
Within Communication Arrangement Work Center, when the Button "Check Connection" is clicked, the error appears such as "Ping Failed" or "Forbidden".
The URL being used is an OData endpoint of the same tenant used.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open Administrator Work Center.
- Go to General Settings view.
- Communication Arrangements.
- Select Relevant Arrangement.
- Select Relevant Service.
- Click on "Check Connection".
- Error 'Checking connection failed' is thrown, possibly with more information such as: "Ping failed" and "Forbidden".
Cause
This Button is meant to Test a Connection between C4C and an Outside system, when the URL used is a OData Endpoint within the same C4C Tenant, it may not behave correctly, throwing errors. This does not mean that the Arrangement is not working, as this is an Issue with the Check Connection function, not the OData Service.
Resolution
It is possible to test if the service is correctly working by performing a simple GET call, if the endpoint returns a response payload, there are no issues with the Service.
In case of SDK environment to build a PDI which calls the endpoint, there is no "Check Connection" option, it is necessary to use a GET call to test instead, as stated above.
See Also
Keywords
Connection; warning; PDI; Integration; Ping Failed; Forbidden; , KBA , LOD-CRM-INT-API , OData API (C4C Only) , LOD-CRM-INT-ERP , Integration of C4C with ERP , AP-RC-BDS-WS , ByDesign Studio Web Services , Known Error