Symptom
You have downloaded some materials from S4 to CPQ and you're unable to delete these products in CPQ.
Even when trying to delete these products in bulk using REST API call (setup/api/v1/admin/products/{id}), since these are backend synched products, we get error.
Error: Products that are synched from back office cannot be deleted.
Environment
SAP SALES CLOUD CPQ
Cause
The “synched from back office” products cannot be deleted from the UI or via API call.
Resolution
Please create a ticket to CPQ Support team along with an excel sheet containing the products and their Product IDs (PIDs), so that we can have our Ops team to run a DB query to delete the products.
See Also
3300146 - How to contact SAP CPQ Support team?
Keywords
delete, backend synched products, delete in bulk, S4 materials, , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To