SAP Knowledge Base Article - Public

3480824 - Sold-to party not displayed for all items for solution order in query c_bsordglacctlineitemqry

Symptom

In SAP S/4HANA Cloud, when executing query c_bsordglacctlineitemqry in "Query Browser (F1068)" and outputting the data, the sold-to parties are not displayed for all solution order items.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

1. Select "GL Account Item for Solution Order - Query" in "Query Browser (F1068)".
2. Output the data.
3. Putting 'Solution Order', 'Solution Order Item' and 'Sold-to Party' as the rows in sequence.
4. Notice that some solution order items do not display the sold-to party.

Cause

- The issue pertains to the business partner data processing of line items.
- These items are all third-party sales items.
- Based on the configuration, these line items do not have their own business partners and instead require retrieving the business partner from the solution order header.

Resolution

1. To get the sold-to party data from the solution order header, add 'solution order', then the 'sold-to party' as the row.
2. Do not add the 'solution order item' in between.

Keywords

SAP S/4HANA Cloud, Sales, Solution Order, Query Browser, Sold-To Party, Business Partner, Third-Party Sales Items, Solution Order Header, , KBA , CRM-S4-ANA-CDS-2CL , S4CRM: Analytics Data Service (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions