Symptom
Error "Item &1: Date type-specific customizing is missing for recurring type &2" occurs when editing service contract renewal, after setting the "Automatic Renewal" flag of a service contract line item.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Create service contract via the "Manage Service Contracts" app.
- Select the "Automatic Renewal" flag of a service contract line item and enter xx weeks, xx year, and YYYY-MM-DD into renewal fields.
- Error "Item &1: Date type-specific customizing is missing for recurring type &2" occurs when editing service contract renewal, e.g. selecting the "Define Prices" button and add xx% non cumulating increase.
Cause
The root cause lies in that duration "&2" is missing in the custom date profile in the configuration activity "Define Date Profile for Service Transactions (ID: 104301)".
Resolution
The solution is to add duration "&2" into the relevant custom date profile.
Keywords
Error, Item, Date type-specific customizing, Missing, Recurring type, Service contract renewal, Automatic renewal, Duration, Define date profile, Service transactions, 104301 , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem