SAP Knowledge Base Article - Public

3481418 - OData API Upsert works fine but data takes long time to reflect in Employee Central

Symptom

A delay is occurring when you are importing data into SuccessFactors Employee Central objects (such as Job Information or Compensation Information) using the OData API.

The Upsert call is successful, but the data is not immediately shown in the employee's profile.

After approximately 10 minutes, the data is finally reflected in the employee's profile.

You want to understand why this delay is occurring.

Environment

  • SAP SuccessFactors HCM
    • OData API

Cause

HRIS Sync is not executed immediately when the data is imported through import tools or APIs.

Resolution

The data will only reflect in the employee profile when HRIS Sync is executed.

Its execution may take some minutes to be triggered after the import is successful, so this delay would be expected to occur in such cases.

Refer to the "Employee Central Data Import or API Operations" section of the Help Portal page Triggering HRIS Sync.

Keywords

import, odata, api, upsert, batch, rehire, delay, processing, long time, hris sync, sync , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , Problem

Product

SAP SuccessFactors HCM Suite all versions