Symptom
The ellipsis appears when using the external product ID instead of the actual product while searching for a product on the Sales Quote.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the Sales work center.
- Access the Sales Quote section.
- Locate and open Sales Quote ABC (where ABC represents the quote ID).
- Proceed to the Products tab.
- Search for the product using the external ID 0000012345; the product will be displayed instantly.
- Repeat the search by copying and pasting *12345; the product will be shown.
- Attempt the search again by manually entering the external product as *12345 (without copying and pasting); the product will not appear, and instead, an ellipsis (...) will be displayed.
Cause
When using external IDs for quick search functionality, there can be performance or timing issues leading to delays in retrieving the search results.
Resolution
If the search results in an ellipsis (three dots), the user should click on it to retrieve the specific or suggested product. This action should resolve the performance or timing issues and provide the desired search results.
Keywords
Ellipsis, External Product ID, External ID, Search , Sales Quote, Product , KBA , LOD-LE-CQP , Customer Quote Processing , Problem