Symptom
Users experience "blank loading screen" issue when using Story Reports which is due to build of cache in system.
Environment
SAP SuccessFactors People Analytics
Reproducing the Issue
1. In SuccessFactors navigate to reporting
2. Try create/run a Story Report
3. Observe the "blank loading screen" issue with the the three dots
Cause
Engineering colleagues have confirmed that "blank loading issue" could occur due to build up of cache as Story Reports rely on cookies in the browser so build-up of cache can negatively affect experience resulting in "blank loading screen issue"
Resolution
Users need to ensure they are correctly logging out of SuccessFactors properly if accessing multiple instances and not just closing the tab of active session.
To avoid having to manually clear cache, in your browser you can set-up that cache is cleared automatically when you close all windows rather than having to manually clear cache.
This can be done in both Chrome and Edge.
In Chrome it is found under Settings > Privacy and Security > Additional Content Settings > On-Device Site Data > Delete data sites have saved to your device when you close all windows
Or in Edge:
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Select Settings and more > Settings > Privacy, search, and services.
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Under Clear browsing data, select Choose what to clear every time you close the browser.
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Turn on the Cookies and other site data toggle.
See guides from browsers:
See Also
3039244 - Unable to access Story Reports due to Browser Settings - MS Edge & Google Chrome
2912865 - [Main KBA] Unable to access Story reports - People Analytics
Keywords
Story Reports, Blank Loading Screen, People Analytics, three dots, Cache, Browser, cookies , KBA , LOD-SF-ANA-SAC-ADM , SF Admin configurations (Security Center, Provisioning) , How To