SAP Knowledge Base Article - Public

3481796 - No Data Displayed In KUT Field After Customer Merge

Symptom

KUT field on Ticket is cleared after merging two Customers.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Create a new customer ABC (where ABC is the ID of the Customer) in the system.
  2. Create 2 tickets for Customer ABC. Make sure that on both tickets the KUT field is populated with a value.
  3. Create a second customer XYZ(where XYZ is the ID of the Customer) in the system.
  4. Create 2 tickets for Customer XYZ. Make sure that on both tickets the KUT field is filled with a value.
  5. In Customer XYZ, click on 'Check for Duplicate Action'.
  6. Then select Customer ABC from Potential Duplicates and click on Merge button.
  7. Give a name to the merge job.
  8. Start the merge job in the Customer Merge menu.
  9. Check after the job has run if there are 4 tickets in Customer XYZ.

So notice that only the initial tickets from Customer XYZ have values retained in KUT field but the tickets from Customer ABC do not have data in the KUT field.

Cause

The KUT fields maintained in Customer ABC and XYZ are empty. In Ticket, the KUT field had the following extension scenario enabled- "Account - General Information to Ticket - General Information". During the merge, since there is an extension scenario maintained, the KUT field will get populated with a value based on that scenario i.e. it will look for what is the value present in the KUT field in Customer header and copy the same value to the merged ticket KUT field.

Since no value is present in the Customer header KUT field of Customer ABC, the tickets related to it will have blank value after the merge.

Resolution

In order to resolve the issue, please ensure one of the following:

  1. Maintain a value in KUT field in Customer Header section so that the related Tickets will get that value, OR
  2. Remove the extension scenario from the KUT field so that the values will remain same as the previous values manually maintained in the tickets.

Keywords

Customer, Account, Ticket, KUT field, Merge, Extension Scenario , KBA , BC-DWB-REP-EXT , Extensibility , LOD-CRM-ACC , Account , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions