SAP Knowledge Base Article - Public

3482036 - Returning old product version

Symptom

  • When adding product synced from back office through catalog, it throws generic Application Error
  • Developer Console trace shows not current active Knowledge Base (older version).
  • Attributes removed from a product being available in the configurator
  • Products available in 2 different categories
  • "Unknown item in BOM" message displayed in ECC.

Environment

SAP SALES CLOUD CPQ connected with back office solution

Reproducing the Issue

There are two ways of reproducing the issue, first when data was deleted from backend and second when the data still exists in backend system:

First scenario:

  1. Open a Quote
  2. Select action Add Item, sending to catalog
  3. Search for desired product
  4. When configuring it, error is thrown
  5. When adding item through quick add, the configuration opens as expected.

Second scenario:

  1. Go to CPQ catalog and search for the problematic product in the category it was removed
  2. Configure (Previous removed attribute will be available)
  3. Add to quote
  4. Save quote and place order
  5. Messages will appear in ECC.

Cause

Different versions of a product synced from back office can have different categories, since all versions are set as active, it will return for each category one version.

If KB has been deleted in back office, it will throw the generic error. If it still present, the configuration will open, with incorrect product version.

Resolution

All versions of product should be defined as the same.

Keywords

KB, Sync, Application Error, CPS, Product version, Catalog, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error

Product

SAP CPQ 2024