Symptom
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Settings work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query "All".
- Search for message ID with error "D-U-N-S number must contain 9 digits".
Cause
The incoming payload has the following nodes (where XYZ corresponds to the Business Partner ID):
<PartyIdentifierTypeCode>BUP001</PartyIdentifierTypeCode>
<BusinessPartnerID>XYZ</BusinessPartnerID>
If a node called PartyIdentifierTypeCode is present in the message payload, and its value is equal to BUP001, it indicates that the BusinessPartnerID node is related to DUNS.
The Dun & Bradstreet D-U-N-S® Number (short for Data Universal Numbering System) is a nine-digit unique identifier for businesses. A DUNS number is sometimes formatted with embedded dashes to promote readability, such as "XX-XXX-XXXX". Modern usage typically omits dashes and shows the number as in the form "XXXXXXXXX". The dashes are not part of D&B's official definition of the DUNS number.
C4C, therefore, only supports nine-digit Business Partner IDs without the dashes.
Resolution
To resolve this issue, send the Business Partner ID from external system in the correct format: A nine-digit number without any dashes. An example of a Business Partner ID in the correct format would be "123456789".
Also, it is not possible to deactivate the D-U-N-S Number Check in C4C system. Please maintain the D-U-N-S Number in the S/4 system without dashes and without prefixes as stated above.
See Also
Keywords