Symptom
When opening certain accounts, a pop-up will automatically appear displaying the message "Your entries have been saved". In certain instances, if the Business Partners are not correctly aligned, it can trigger a message to S/4HANA, potentially resulting in the deletion of important values within the system.
Environment
- SAP Cloud for Customer
- SAP S/4HANA
Reproducing the Issue
- Go to the Customer work center.
- Go to the Accounts work view.
- Search and open the Account 456 (where 456 means the Account ID).
- The message “Your entries have been saved” appears at the top of the screen.
Cause
The fact that a save is triggered when the TI opens, it's usually related to a Custom Embedded Components triggering an action call with save. As an example:
- UI Component: /Y.........._MAIN/SRC/EmbeddedComponents/EC_AccountsCalculationFields.EC.uicomponent
Event handler: EV_CalculationFields - BO Name: BUPA_SOLUTION_EXTENSIONS
Action: Y........_C....................
Resolution
This scenario works according to customer's implementation. If the requirement is to eliminate this activity, customer needs to review the customization in order to remove the call to the custom action with save.
There are more appropriated channels to handle inquiries related to custom implementation rather than an application issue or defect, such as the SAP Cloud Applications Studio. In this Community, numerous ABSL Developers from SAP and Partner Environments are available to assist with such requests.
Keywords
Cloud for Customer; C4C; S/4 HANA; Embedded Components; custom; customization. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To