SAP Knowledge Base Article - Public

3482703 - Interviews and availability not visible in My Calendar when changed to Thai language

Symptom

Interviews and availability not visible in My Calendar under Interview Scheduling when language is changed to Thai

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

1. Go to Settings and switch to Thai language
2. Go to Recruiting > Interview Scheduling > My Calendar
3. Scheduled interviews and availability are not visible.

Cause

When the language (locale) is set to Thai, it is trying to fetch the availability as per Hijri calendar.  Since the date is stored in Gregorian calendar, it is not able to find the slot as per Thai locale calendar.

Resolution

This is a known issue, and the code fix is currently being worked on. The fix is not easy to implement and might impact other areas of the application.  

Engineering team have created the story, to provide a long-term fix for this. There is no commitment for this yet but are hoping to deliver this for 2411 release.

Keywords

My Calendar, Interview Scheduling, Thai, RCM-127776 , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem

Product

SAP SuccessFactors Recruiting 2405