Symptom
When replicating Business Partners from S4 to CPQ using SOAP API, you're getting API disabled response in CPQ.
Your tenant is on Quote 2.0 engine, and Business Partners feature is already enabled in your tenant.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
You're using Customer Administration SOAP API with ADDORUPDATE action.
And you see the below response from the API call:
<CustomerAdministrationResponse xmlns="http://webcominc.com/" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<CustomerAdministrationResult>
<Response xmlns="">
<Result>NOK</Result>
<Error>
<Code>100000</Code>
<Message>Admin.CustomerAdministration.ApiDisabled</Message>
</Error>
</Response>
</CustomerAdministrationResult>
</CustomerAdministrationResponse>
Cause
This error happens when you are consuming the API for Customers, and as you are on Quote 2.0 with Business Partner enabled, this is not the correct API.
Resolution
Please use Business Partners REST API call.
You can find it on Swagger: https://webcomcpq.com/webapihelp/index#/BusinessPartner
See Also
Keywords
API disabled response, ApiDisabled, 100000, error code, business partners, BP, REST API, SOAP API, CustomerAdministration, Customer Administration SOAP API, , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem