Symptom
The "Resolution Duration" attribute under Ticket data source is not showing correct output, particularly showing zero for some tickets.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Open the affected report/data source from Business Analytics/Analysis work center.
2. Filter by Ticket ID field under selection tab.
3. Click on Run report
4. Go to to View tab and select the field Resolution Duration.
5. Click on Run Updates.
6. You will see the Resolution Duration as 0.00
Cause
The "Resolution Duration" is showing 0.00 because if the resolved on time point is greater than the request initial receipt time point, then duration will be calculated, and if not it will be set to 0.
Resolution
Set the resolved on time point lower than the request initial receipt time point, then duration will be calculated.
Keywords
Resolution Duration, Ticket, Key Figure , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem
SAP Knowledge Base Article - Public