SAP Knowledge Base Article - Public

3483791 - Salesforce.com connection missing in Crystal Reports

Symptom

  • Salesforce connection missing in the Database Expert.
  • Unable to create a report based on Salesforce.com in Crystal Reports.
  • Used to be able to create reports to Salesforce from Crystal Reports before.

Environment

  • SAP Crystal Reports 2020
  • SAP Crystal Reports 2025

Reproducing the Issue

  1. In Crystal Reports, create a new report.
  2. In the Database Expert, expand "Create New Connection"
  3. In the list of connections, the Salesforce.com option is missing.

Cause

  • Salesforce connection has been removed from Support Pack 04 of Crystal Reports 2020.
  • Crystal Reports Salesforce.com driver (OEM) is no longer supported by the OEM vendor starting from December 2023, and therefore this is why the Salesforce connection has been removed from Support Pack 04.
       
  • For reference, see Crystal Reports 2020 supported platforms document found in the SAP Knowledge Base Article:
       
    2859510 - Supported Platforms documents for Crystal Reports

Resolution

  • To connect to Salesforce, use a third party ODBC / JDBC driver.

Keywords

CR, sforce, saleforce , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2020 ; SAP Crystal Reports 2025