Symptom
When trying to set up the Employee Central Quick Actions for view emergency contact and change emergency contact, we are receiving an error message "The fields (primary_flag, relationship, name, phone) must be included in the template for the View Emergency Contacts use case.".
*Image/Data in this KBA is from SAP internal systems, sample data or demo systems. Any resemblance to real data is purely coincidental*
Environment
SAP SuccessFactors Employee Central - Employee Central Quick Actions
SAP SuccessFactors Employee Central - Emergency Contact Information
Reproducing the Issue
Prerequisite - Configured Employee Central Quick Action Template, refer to Configuring an Employee Central Quick Action Template | SAP Help Portal.
Steps -
- Navigate to Manage data > Create New > Employee Central Quick Action Template.
- In Use Case search for View Emergency Contacts/Change Emergency Contacts.
- Scroll down and click on Save.
- Observe Error "The fields (primary_flag, relationship, name, phone) must be included in the template for the View Emergency Contacts use case.".
Cause
Primary [primary_flag] is a required field in Emergency Contact information.
Resolution
- Navigate to Manage Business Configuration > Emergency Contact Information [emergencyContactPrimary].
- Add the field 'Primary [primary_flag]' and save it.
- Once the field is added, we can add the View Emergency Contacts/Change Emergency Contacts Template in Quick Actions.
View:
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide: Configuring an Employee Central Quick Action Template
See Also
- 3483830 - Unable to add Employee Central Quick Action for View and Change Emergency Contact in Manage data
- 3458083 - Employee Central Quick Actions do not respect field-level permission
- 3540347 - Employee Central Quick Actions for emergency contact or other picklist field are showing external code in the picklist
Keywords
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