Symptom
When trying to set up the Employee Central Quick Actions for view emergency contact and change emergency contact, we are receiving an error message "The fields (primary_flag, relationship, name, phone) must be included in the template for the View Emergency Contacts use case.".
Environment
SAP SuccessFactors Employee Central - Employee Central Quick Actions
SAP SuccessFactors Employee Central - Emergency Contact Information
Reproducing the Issue
Prerequisite - Configured Employee Central Quick Action Template, refer to Configuring an Employee Central Quick Action Template | SAP Help Portal.
Steps -
- Navigate to Manage data > Create New > Employee Central Quick Action Template.
- In Use Case search for View Emergency Contacts/Change Emergency Contacts.
- Scroll down and click on Save.
- Observe Error "The fields (primary_flag, relationship, name, phone) must be included in the template for the View Emergency Contacts use case.".
Cause
Primary [primary_flag] is a required field in Emergency Contact information.
Resolution
- Navigate to Manage Business Configuration > Emergency Contact Information [emergencyContactPrimary].
- Add the field 'Primary [primary_flag]' and save it.
- Once the field is added, we can add the View Emergency Contacts/Change Emergency Contacts Template in Quick Actions.
Keywords
quick action, employee central, Primary, primary_flag, The fields (primary_flag, relationship, name, phone) must be included in the template for the View Emergency Contacts use case, The fields (primary_flag, relationship, name, phone) must be included in the template for the Change Emergency Contacts use case, error, manage data, emergency contact information, emergencyContactPrimary, template , KBA , LOD-SF-EC-PER-ECO , Emergency Contact Details , LOD-SF-EC , Employee Central , Problem