Symptom
Defined Workflow rules has "Create Email Activity" is set to "ON". However, workflow rule does not create Email activities after a contact is created under Account.
After contact creation workflow rule does not create Email activities under Accounts even though in Workflow rules "Create Email Activity" is turned ON.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customer work center.
- Go to Account work center view.
- Search and open an Account.
- Go to Activities facet.
- In E-Mails field, E-mails are not being created after new contacts are created even though in workflow rules "Create Email Activity" is turned ON.
Cause
Under Workflow Setting's Activity Creation "Determine Account and Contact from source object for the Activities created through Workflow Rules" Checkbox is disabled.
Resolution
Select the respective workflow rule and click on "Workflow Settings" dropdown under "More" Button.
Enable the checkbox of "Determine Account and Contact from source object for the Activities created through Workflow Rules".
Keywords
Workflow, Account, Activities, Email, Contacts , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-ACC , Account , LOD-CRM-CON , Contact , Problem