SAP Knowledge Base Article - Public

3484218 - The New Registered Product is Created Without a Contact

Symptom

It is allowing to create New Registered Product, even for an Account without any Contact.

Environment

SAP Cloud for Customers.

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Search and open account LMN (where LMN represents the account name).
  4. Go to the Contact facet of account LMN.
  5. You can see there is no contact maintain here.
  6. Go to the Installed Base work center.
  7. Go to the Registered Product view.
  8. Click on + button to create New Registered Product for an account LMN, maintaining other mandatory details.
  9. You are allowed to create new registered product though account LMN have no contact maintained.

Cause

During creation of new registered product, system checks for contact determination from account master data. If an account master data has contacts maintain, then during registered product creation if the determined contact is obsolete/inactive an error will trigger else registered product will be successfully created for the determined active contact of an account.

However, if there is no contact maintain in the account master data then no active/obsolete contact gets determine during registered product creation and hence it will allow creating it without contact value.

Resolution

This is an expected system behavior.

Keywords

New Registered Product, Contact Determination, Active or Obsolete Contact, No Contact in Account master data , KBA , LOD-LE-IBA-IPO , Installation Point , LOD-LE-IBA-IBA , Installed Base , Problem

Product

SAP Cloud for Customer core applications 2405