SAP Knowledge Base Article - Public

3484259 - Raise a MDF Alert Message if there is No Payment Information maintained after X month from Hire Date or Rehire

Symptom

Raise a MDF Alert Message if there is no Payment Information maintained after 1 month from Hire Date or Rehire

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors - Payment Information

Reproducing the Issue

Step 1: Create Run

Step 2: Add rule under Object definition: Payment Information

Step 3: Create a rule trace

Step 4: Proxy as EC alert job owner

  • Run job

Step 5:Check result

  • Check Rule trace
  • Result: blank and No email has been triggered

Cause

  • Working as design 
  • The rule configured on Post Save of Payment Information MDF Object has conditions referring to the Worker-> Job Information
  • here the if condition checks for new hire, rehire, transfer cases where a new user creation happens and the rule which is on post save gets executed before the user is created as per the process
  • When there is no user yet existing in the system during rule execution from hire or rehire, how can we check a condition from the user's data. This is the reason

Resolution

This is not possible

  • Since this rule is applicable only during hire/rehire scenarios and there is no user created yet during the time of rule execution, worker will not be found. Hence the MDF alert will also not work.
  • Basically any rule condition trying to access Worker during the hire/rehire scenarios will not have any affects

Additional Information:

This is out of scope on Support side but customer can contact

Please find this information documented in a blog:  Alerts for Payment Information: Full step-by-step guide

URL: https://community.sap.com/t5/human-capital-management-blogs-by-members/alerts-for-payment-information-full-step-by-step-guide/ba-p/13561894

NOTE: This is an example of alert payment information  and therefore it is outside the scope of SAP Cloud Product Support. If customer raises a case, please direct them to the above blog and if they run into any difficulty, they need to reach out to their partner /Professional Services team who will be able to assist them further.

Keywords

Payment Information, rule , alert, Hire, rehire, worker , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem

Product

SAP SuccessFactors HCM Core 2405

Attachments

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