SAP Knowledge Base Article - Public

3484342 - System Allows User to Create A Customer Return Notification for A Sold Product with Obsolete Identified Stock

Symptom

The system encounters below errors when creating a Customer Return Notification (CRN) for a sold product with obsolete identified stock. However, it still creates an Inbound Delivery Notification and a Customer Return document.

"Error during warehouse request release

Associated identified stock A is obsolete. Mark Stock as Restricted.

Deletion of request ID is not permitted

Zero Quantity for request ID, item ID B is not permitted. Add a quantity greater than zero or reject the requested item"

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Inbound Logistics Work Center.
  2. Choose New Customer Return Notification in Common Task.
  3. Search for the Sales Order ID.
  4. Select the record and choose Next.
  5. Fulfill the Delivery Notification ID and the return reason.
  6. Choose Next.
  7. Choose Finish and Create Warehouse Request, then the document would be created even if the mentioned error occurs.

Cause

After analyzing the issue, we have identified that there is currently no system check in place to determine if the identified stock is obsolete or not when creating a CRN.

Resolution

This issue has been permanently resolved since 2411 release.

If there is any inconsistent CRN created before that, please report a case to us and we will help delete the CRN from backend.

See Also

3543975 - Error "Insufficient Stock for the Product" Triggered When Creating New Over-the-Counter Sale https://me.sap.com/notes/3543975

Keywords

Error during warehouse request release, Associated, Identified Stock, Obsolete, Customer Return Notification. , KBA , AP-IDP , Inbound Delivery Processing , Problem

Product

SAP Business ByDesign all versions