Symptom
Email is also sent to inactive users included in the permission group which is configured as Dynamic Group Recipient Builder for the email template.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to Admin Center >> Email Services
- Create a custom email template >> configure a permission group as Dynamic Recipient Builder
- Terminate 1 user from the permission group >> user becomes inactive in system
- Trigger onboarding for a new hire
- Go to Admin Center >> Email Services >> Email Status
- See the email recipient still includes the inactive user
Cause
A gap in current product.
Resolution
- This issue will be corrected in the 2H 2024 (b2411) Release.
- Release dates can be found on SAP SuccessFactors Product Release & Road Map Information
Workaround:
Changing the filter for permission group to exclude the inactive users so that emails will no longer sent to them.
For Live Customer:
In case you'd like to have more details about the fix, please kindly reach our to your Customer Success Partner (CSP) and refer to the JIRA ticket #OBX-31334.
Keywords
SuccessFactors, Onboarding, email, Dynamic Recipient Builder, inactive , KBA , LOD-SF-OBX-EML , Notifications , Problem