SAP Knowledge Base Article - Public

3484815 - Changes to a Customer's name do not reflect in the title of the Customer object

Symptom

When changing the name of a Customer in the object header, the changes are not reflected in the title of the object or in the Customer OWL, only in the First Name and Last Name fields in the object header.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Open any Customer or Employee
  2. Edit the First Name and Last Name fields in the header
  3. The title of the object is not updated

Cause

The Deviating Full Name field is filled.

The Deviating Full Name is used when an individual's name is different from the standard or expected format (e.g. abbreviated, hyphenated etc).  If this field is filled, then this is what will reflect in the title of the object, and changing the First Name/Last Name fields will have no affect here.

Resolution

Remove the data from the Deviating Full Name field or change the name directly in this field.

Please note that you may need to make the field visible via adaptation.

Keywords

deviating full name, customer name, change customer name, cannot change customer name, employee, individual customer, account , KBA , LOD-CRM-EMP , Employee , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer core applications 2405