SAP Knowledge Base Article - Public

3484940 - The Delivery Status and Invoice Status are Displayed as Finished After a Reason for Rejection is Maintained for a Item in Sales Order or Service Order

Symptom

When maintaining a reason for rejection for a item in a Sales Order or Service Order, the Delivery Status and Invoice Status of the Item automatically changes to Finished.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Order Work Center.
  2. Go to the Sales Order View.
  3. Filter for All Orders.
  4. Search for the Sales Order ABC (where ABC represents the Sales Order ID).
  5. Open, Select View All.
  6. Navigate to the Item tab.
  7. Mark the Line Item XX (where XX represents the Line Item number).
  8. Maintain a Reason for Rejection for the Item.
  9. Select Save.
  10. Close the Sales Order ABC.
  11. Open the Sales Order ABC again.
  12. Navigate to the Item tab.

The Delivery and Invoice status of the Item XX is displayed with status as "Finished".

Cause

Once a Item is rejected via reason for rejection in a Sales Order or Service Order with status as In Progress or Open, the Delivery and Invoice status of the Item automatically changes to Finished as per the system behavior.

Please note that there are exceptions for this scenario, for example when there is a 3PL Request document in the Sales Process, however for most of the scenarios the Delivery and Invoice status of the Item will change to Finished once a reason for rejection is set for the item.

Additional note: if a Item is canceled in a Sales Order or Service Order with status as In Preparation, then this Item will remain with status as Not Started and will not change to Finished.

Resolution

This is the current designed system behavior.

Keywords

sales order, service order, finished, item, status, in progress, not started, open, delivery status, invoice status , KBA , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions