Symptom
When performing a bulk upload of cost reassignment records via the Reassign Cost and Revenues App, the system terminates the upload session with a connection error at approximately 10 minutes, regardless of the configured session timeout defined value.
Environment
SAP S/4HANA Cloud Public Editon
Reproducing the Issue
- Open the Reassign Cost and Revenues App (F2009A)
- Prepare the file with all cost reassignment records that need to be uploaded in the system.
- Initiate journal entry creation and select the 'Upload' option.
- Upload the file (System confirms: 'File upload successful. Please review the data.' and the first records are displayed).
- Proceed to load all records (System begins processing the full quantity of records).
- After approximately 10 minutes of active processing, a connection error is received and the session terminates.
Cause
It's a standard system behavior, when uploading a high volume of entries in one time.
Resolution
To avoid the timeout error, It's recommended to use the following API when bulk uploading/mass posting in Reassign Cost and Revenues App (F2009A): Cost and Revenue Reassignment – Read, Create. Or to split the file for online upload via Fiori App to max. 1000 lines.
See Also
SAP API Overview: Overview | Cost and Revenue Reassignment – Read, Create | SAP Business Accelerator Hub
SAP Help Portal: Cost and Revenue Reassignment – Read, Create | SAP Help Portal
Keywords
Fiori App, app id, F2009A, API functionality, Activity Allocation, Timeout, Error, Connection, Reassign Cost and Revenues App, Bulk, File Upload , KBA , CO-FIO-CCA-TRA-2CL , Transactions (Public Cloud) , Problem
SAP Knowledge Base Article - Public