SAP Knowledge Base Article - Public

3485283 - BusinessPartnerSolution Extension Is Not PSM Released for OData Services

Symptom

The fields added to the BusinessPartnerSolutionExtensions BO via PDI cannot be Created or Updated to any OData services (custom or standard).

Environment

SAP Cloud for Customer

Cause

The fields are not creatable in the OData services since the root node of the BO BusinessPartnerSolutionExtensions is not PSM write released.

This is evaluated by our OData services and therefore root extension fields can't be set to creatable/updatable.

Resolution

We would like to provide some workarounds for you to explore and confirm if that suffice your business requirement.

OPTION 1:

Please try to add the extension fields to COMMON node of BusinessPartnerSolutionExtensions.

If no further BP common extension fields can't be added anymore, please delete the unwanted ones and try to cross-check if you can add further fields to the common nodes.

OPTION 2:

You can explore trying to achieve this scenario by PDI implementation by developing a Cloud Application
By adding a custom node to the BusinessPartnerSolutionExtensions with cardinality 1 and add the required attributes there.

Please refer to the below documentation for more details:

Help Document > SAP Cloud Application Studios > Node (Business Object Extension)

Help Document > Node Cardinality

Examples:

  • node <name> [ <multiplicity> ]? {[ <Element>, <Node> ]* };
  • [Extension] businessobject AP.CRM.Global:SalesOrder { node Item { }}

See Also

KBA 2414455 - How to Enable Custom Business Objects and Extension Fields in OData and Data Workbench

Keywords

custom, odata, service, custom, business, object, data, extension, field, PDI, SDK,  , KBA , LOD-LE-BP-BP , Business Partner , LOD-CRM-INT-API , OData API (C4C Only) , Problem

Product

SAP Cloud for Customer core applications all versions