Symptom
Duplicate Workflows appear in My Workflow Requests page (also known as "advanced to-do page") of the user on multiple employments.
However in the Home page, the behavior is user based; the user can view the number of workflows in the Approval Card only assigned to the current User Id.
Environment
SAP SuccessFactors Employee Central - Workflows
Reproducing the Issue
For a user with Multiple Employments, where both the employments are steps approvers for the same workflow then duplicate workflows appear in My Workflow Requests page.
Cause
This is expected behavior for a user with multiple employments like Concurrent Employment, Global Assignment or Higher Duty Assignment. as the My Workflow Requests (Advanced To-Do) page is not user based.
However in the Home Page > Approval tile, it shows the number of workflows based on the User ID, so it is not duplicated.
Resolution
To request a change in current system behavior, you can submit an enhancement request through the SAP Customer Influence portal.
SAP Customer Influence is a great program for customers and partners to share feedback/ideas that help enhance SAP solutions in production. It enables customers to submit ideas and to vote on them.
These requests are reviewed by product management for potential inclusion in future releases, as detailed in the KBA - 2090228.
Keywords
Duplicate workflows, concurrent employment, multiple employments, My Workflow Requests page, advanced to-do page, Global Assignment, Higher Duty Assignment. , KBA , LOD-SF-EC-WFL-REQ , My Pending Requests, ToDo's & Mass Approvals , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-CON , Concurrent Employment , LOD-SF-EC , Employee Central , LOD-SF-EC-HDP , Higher Duties & Public Sector , LOD-SF-EC-GA , Global Assignment , Product Enhancement
SAP Knowledge Base Article - Public