SAP Knowledge Base Article - Public

3485755 - Users encounter ISSM-004: Foreign customization detected in user’s mailbox - set by instance "myxxxxx.crm.ondemand.com". error while configuring user from test to production tenant

Symptom

User tries to connect C4C to Outlook using server-side outlook integration and encounters the error below 

"ISSM-004: Foreign customization detected in user’s mailbox - set by instance "myxxxxx.crm.ondemand.com". 

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Login to C4C as user.
  2. Navigate to Email integration>user settings.
  3. User encounters error - "ISSM-004: Foreign customization detected in user’s mailbox - set by instance "myxxxxx.crm.ondemand.com".

Cause

If the mailbox is already connected to one tenant, the user will always receive this error message when trying to connect to another tenant using the same mailbox, until the "Mailbox customization" is removed/deleted from the initial tenant the user will keep getting the mentioned error.

Resolution

  1. If you still have access to the initial tenant, which is shown in the message, log in to that tenant as a Key User.
  2. Go to E-Mail Integration > Groupware Setting > Users and find a user who is experiencing an error.
  3. Open the user profile, click the “Gear” button in the upper right corner and click Reset mailbox.
  4. Once mailbox is reset, log in to the new tenant and start the synchronization.

Method 2

  1. Log in as a Key User on affected tenant.
  2. Go to E-Mail Integration > Groupware Setting > Users and find a user, who is experiencing an error.
  3. Open the user profile, click the “Gear” button in the upper right corner and click Re-initialize User’s mailbox.
  4. Once user’s mailbox is re-initialized, start the synchronization.

Keywords

C4C, Server-side Integration, Outlook, ISSM-004 , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem

Product

SAP Cloud for Customer core applications 2405