SAP Knowledge Base Article - Public

3485995 - Error message 'Entity SLINE is not available' received when trying to create a Sales Order

Symptom

When trying to create a Sales Order using the SOAP API OrderRequest_In, the error message "Entity SLINE is not available" (GOAL 051) is received.

Environment

SAP S/4HANA Cloud Public Edition

Cause

Missing configuration. The system couldn’t determine the material, so the schedule line is not available.

Resolution

Configure customer material.

You can refer to chapter '2.2.12 - Maintain Customer Material' on the Set-up instructions of 2EL - Integration of Sales with External Buyers.

  1. Open the 'Manage Customer Materials' app.
  2. Maintain the internal material which will be sold to the related sold-to party, sales organization, distribution channel, and customer material.

Keywords

Entity SLINE is not available, GOAL051, SOAP API, OrderRequest_In, 2EL, 3ZB, Manage Customer Material, schedule line, customer material, internal material , KBA , SD-SLS-EDI-2CL , S/4HANA: Sales EDI Messages (Public Cloud) , SD-SLS-API-2CL , API (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions