SAP Knowledge Base Article - Public

3486460 - Manage My Team Quick Action not working in MS Teams integrations

Symptom

"Manage My Team" Quick Action not working in MS Teams integrations. Error "Unable to Load Data" or "Unable to reach app" pops-up.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HCM

Reproducing the Issue

  • Go to the MS teams App for SF
  • Type Manage My Team in the chat you will then get the "My Team" button suggested by the app.
  • Click it.
  • Two things can happen, behavior is random:
    1) The error "Unable to load data" or "Unable to reach app" shows up after a few seconds of loading
    2) The direct reports will show up, but once you click any of them, you will get "Unable to load data" or "Unable to reach app" after a few seconds of loading

Cause

"Manage My Team" card has the dependency that EC Snack should be enabled and configured properly.

Resolution

EC Snack should be configured first. Please check this guide: https://help.sap.com/docs/SAP_SUCCESSFACTORS_EMPLOYEE_CENTRAL/b14dd15ca58f43e0856184a740a4b212/3223bf1156204810b894cb185d9b3885.html

An enhancement is currently being worked on by the engineering team to ensure that if EC Snack is not configured, the "Manage My team" action will not be available in the Teams app. Target date for this enhancement is in July 2024.

See Also

https://help.sap.com/docs/SAP_SUCCESSFACTORS_EMPLOYEE_CENTRAL/b14dd15ca58f43e0856184a740a4b212/3223bf1156204810b894cb185d9b3885.html

Keywords

MS teams, Worktech, Manage My team, Quick action, Teams, integration, SuccessFactors, Microsoft, Teams , KBA , LOD-SF-EAS-WRK , Collaboration and Work Tech , Problem

Product

SAP SuccessFactors HXM Core 2311

Attachments

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