SAP Knowledge Base Article - Public

3486656 - Servcie Order Item with Type as DIGI is Not Delivery Finished Status After Service Confirmation Released for it

Symptom

In the service order ABC, the line 10 is with item type as 'Spare part - direct goods issue' (DIGI). You have created and released the service confirmation for this line 10, but the delivery status is still Not Started.

ABC represents the ID of the service order.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Orders work center.
  2. Go to the Service Order Processing view.
  3. Open the order ABC, in Services and Spare Parts tab, select line 10 and you can see the delivery status is Not Started.
  4. Go to the Document Flow tab, open the service confirmation DEF. (DEF represents the ID of the service confirmation), it is Finished status.
  5. In Services and Spare Parts tab, the line is referenced to to the service order ABC line 10 correctly.

You want to know why the delivery status in the service order is not updated.

Cause

For item with type 'Spare part - direct goods issue', the delivery status is updated when the line is completely finished. Since the service confirmation was released without completion, the delivery status is not get updated.

Resolution

You can complete the line by release the confirmation with completion.

  1. Open the service confirmation DEF.
  2. Click Release - With Order Completion.

The delivery status in service order ABC line 10 is then updated to Finished.

Keywords

service order; Spare part - direct goods issue; delivery status; release with order completion. , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions