SAP Knowledge Base Article - Public

3486663 - Activities logs show duplicated rows when opening analytics application in SAP Analytics Cloud(SAC)

Symptom

When opening an analytics application with below format, two rows for same activity 'Read' will generate in Activity Logs. 

  • https://<TENANT>/sap/fpa/ui/app.html#/analyticapp?shellMode=embed&/aa/<STORY_ID>

Environment

SAP Analytics Cloud

Reproducing the Issue

  1. login SAC.
  2. open a page for Activity.
  3. open a new tab with analytic application url: https://<SAC tenant>/sap/fpa/ui/app.html#/analyticapp?shellMode=embed&/aa/<STORY_ID>.
  4. check in Activities, two rows are generated for it. Both of them are for 'Read' action, and only the timestamps are different.
  5. open a new tab with analytic application url: https://<SAC tenant>/sap/fpa/ui/app.html#/analyticapp&/aa/<STORY_ID> /?mode=view.
  6. check in Activities again, only one row is generated for it.

Cause

  • The application currently fetches data whenever the "embed status" within the URL changes between "mode=view" and "shellMode=embed." This triggers a page reload, resulting in additional data reads.
  • The reload behavior worked by design. 

Resolution

This is by design.

See Also

Keywords

SAP Analytics, SAC, Activity, Application , KBA , LOD-ANA-AD , Analytics Designer , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud all versions