Symptom
'Overtime Category' field is not displayed under the Details section of app 'Manage My Timesheet', when user select/create a time entry related to a project demand.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open app 'Manage My Timesheet';
- Select an existing time entry related to a project or create a new one and select it;
- Notice that the Overtime Category field won't be displayed in the Details section.
Cause
There are two possible causes for this behavior:
- The employee related to the task is a contingent worker;
OR
- The task comes from a object/project different than Customer or Internal projects (for instance, an Enterprise Project).
The Overtime Category field is only available for internal employees to record time for Customer or Internal project.
Resolution
In order for employees to be able to enter the Overtime Category when booking time, the project demand needs to be generated from a customer or internal project, and has to be assigned to an internal worker.
See Also
For further information, check the following link: SAP Help Portal - Manage My Timesheet.
Keywords
S/4HANA Cloud, overtime, overtime category, timesheet, time sheet, project, task, my tasks, details, J12 , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem