Symptom
Extension fields created from PDI solution are missing in the UI.
Environment
SAP Business Bydesign
Cause
The extension field visibility is controlled by UI Switches added by Partners and these conditions are returning "False" due to the below reasons.
- The necessary UI Switches is not assigned to the business user through business role.
- The UI Switch of the business user has a conflict in configuration. For example, the same field in one UI switch is set as visible but in another UI switch is set as invisible.
Resolution
UI Switches are assigned to business user through business role. The assigned UI Switches of a particular business role can be checked as following:
- Go to Application and User Management - Business Roles.
- Edit the target business role.
- Navigate to the UI Switches Tab.
Case 1:
Guarantee that all the necessary UI Switches are assigned to the business user by business role.
Case 2:
Guarantee that all the UI Switches which are assigned to the business user are not conflicted.
Keywords
PDI fields, Invisibility, UI Switches, Business Role , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , AP-RC-BDS-1O , ByDesign Studio OneOffs , Problem