Symptom
When creating a sales order the invoicing schedule percentages are not working as expected when alternating between either two or three individual dates.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Open the Sales Orders view.
- Select New -> Sales Order.
- Add a product/service.
- Maintain a list price (for this example 111.00 of a given currency).
- Go to the Pricing and Invoicing tab, then the Invoice Schedule subtab.
- Add the Item, then two dates.
- For one date input a percentage of 33.33%, then the other 66.67%.
- The overall percentage reads as 100%.
- Now add another date, removing the existing percentages.
- For two dates input the percentage of 33.33%, then the third as 33.34%
- The overall percentage reads as 100.009%.
Cause
This is the expected system behavior. Invoice schedule percentages in the backend round to 5 decimal points.
Resolution
There are two methods of amending this:
Solution 1:
Simply select the amount of the item which deviates from the others, amend the amount to the same as the other two and it will make all three percentages uniform.
Solution 2:
- On the Invoice Schedule subtab, select Edit Invoicing Time Frame
- Add Row -> Recurrence Type: Individual Dates
- Add three dates then apply them to the line item in question
Once complete it will uniformly spread the invoice percentage across the dates.
Keywords
invoice schedule, percentage, dates, time frame, Recurrence Type, Individual Dates, incorrect overall percentage. , KBA , SRD-CRM-INV , Customer Invoicing , How To